When you connect to this website, you send your IP address and sometimes some cookies. You may also give us personal identifying information, such as your name and contact information. All this data is used to securely provide you with the services that you request. We encourage you to review our privacy policy to make sure that you understand how your data is managed, and to contact us if you have any questions. View Privacy Policy

Difference between revisions of "NASPA Zyzzyva Linux Installation"

From NASPAWiki

You are viewing a condensed mobile version of this NASPA webpage.
Switch to full version.

(Collins Zyzzyva)
(2019-07-14 - Updated instructions per Ross Brown)
 
(One intermediate revision by one other user not shown)
Line 1: Line 1:
[[NASPA Zyzzyva 3.2.0|NASPA Zyzzvya Release 3.2.0]] is now available for [[NASPA Zyzzyva Download|download]] for NASPA members.
+
[[NASPA Zyzzyva 3.2.1|NASPA Zyzzvya Release 3.2.1]] is now available for [[NASPA Zyzzyva Download|download]] for NASPA members.
 
If you are not a NASPA member, please download
 
If you are not a NASPA member, please download
 
[https://www.collinsdictionary.com/scrabble/scrabble-tools/ Collins Zyzzyva] instead.
 
[https://www.collinsdictionary.com/scrabble/scrabble-tools/ Collins Zyzzyva] instead.
 
   
 
   
The Linux package is a tarball containing an installer that you can unpack to any location you prefer. It has been tested on Ubuntu "Trusty Tahr" and on Debian "wheezy" with an upgrade of the *libc6*library to "jessie" as required by one of the package dependencies.
+
== Minimum Version Numbers for Common Linux Distributions ==
  
== Installation Pathnames Containing Space Characters ==
+
* Linux Mint 19
 
+
* Ubuntu 17
Due to a problem with the installer, we do not currently recommend installing NASPA Zyzzyva in a Linux path containing space characters. If you need to do so, you will need to hand-edit the launch script, replacing each occurrence of $DIR with "$DIR".
+
* openSUSE 15
 +
* Debian “buster”
  
 
== Linux-specific Changes in this Release ==
 
== Linux-specific Changes in this Release ==
  
* Previous releases consisted of a tarball of the distribution files. Beginning with this release, the tarball contains an installer.
 
 
* If you want to install the software in the default location (/opt), you must sudo the installer.
 
* If you want to install the software in the default location (/opt), you must sudo the installer.
 
* If you want to install the software in a user-writable location (such as ~), you may so configure the installation process.  
 
* If you want to install the software in a user-writable location (such as ~), you may so configure the installation process.  
Line 18: Line 18:
  
 
For general changes since the previous release (3.1.0), please see the  
 
For general changes since the previous release (3.1.0), please see the  
[[NASPA Zyzzyva 3.2.0|release page]].
+
[[NASPA Zyzzyva 3.2.1|release page]].
  
 
Please use the Zyzzyva Facebook group or the naspa-zyzzyva Yahoo! Group to report issues and to communicate with other users and the author.
 
Please use the Zyzzyva Facebook group or the naspa-zyzzyva Yahoo! Group to report issues and to communicate with other users and the author.

Latest revision as of 20:27, 14 July 2019

NASPA Zyzzvya Release 3.2.1 is now available for download for NASPA members. If you are not a NASPA member, please download Collins Zyzzyva instead.

Minimum Version Numbers for Common Linux Distributions

  • Linux Mint 19
  • Ubuntu 17
  • openSUSE 15
  • Debian “buster”

Linux-specific Changes in this Release

  • If you want to install the software in the default location (/opt), you must sudo the installer.
  • If you want to install the software in a user-writable location (such as ~), you may so configure the installation process.

See Also

For general changes since the previous release (3.1.0), please see the release page.

Please use the Zyzzyva Facebook group or the naspa-zyzzyva Yahoo! Group to report issues and to communicate with other users and the author.